Monitoring
Post-call processing has returned to normal levels.
Monitoring
Post-call workflow processing throughput has been rising steadily over the last 2 hours to reach normal levels. The backlog of queued workflows has steadily been draining. We are coordinating with our subprocessor closely to continue monitoring the siutation.
Monitoring
Our subprocessor that handles our post-call processing and PMS-related workflows is experiencing degraded performance, which is causing delays. We are in contact with them and are closely monitoring the situation to determine if we need to take further action.