Degraded service due to global outage
Resolved·Full outage

All services are fully operational again.

Mon, Oct 20, 2025, 10:24 PM
(1 month ago)
·
Affected components
Inbound calls
Notifications
Updates

Resolved

All services are fully operational again.

Mon, Oct 20, 2025, 10:24 PM

Monitoring

Email notifications have now resumed. The notification queue that has built up over the last few hours is gradually clearing up. We will continue monitoring the situation until everything is back to normal

Mon, Oct 20, 2025, 09:18 PM(1 hour earlier)

Monitoring

Inbound calls have been operating smoothly, but will continue to be monitored closely. Email notifications are still impacted by the outage. All email notifications since the start of the outage have been stuck in the queue, and have not been sent out.

Mon, Oct 20, 2025, 08:31 PM(47 minutes earlier)

Monitoring

Our third-party dependencies are now stable, but require close monitoring. We have started enabling inbound calls again, and will be monitoring for any degraded performance.

Mon, Oct 20, 2025, 07:53 PM(37 minutes earlier)

Monitoring

A significant portion of AWS (Amazon Web Services) services are still down, which impacts third-party dependencies. AWS has released an update that a solution is live and is being monitored.

Mon, Oct 20, 2025, 06:58 PM(55 minutes earlier)

Monitoring

A global AWS outage is causing many downstream services to experience outages. While our AWS service is not directly impacted, many third-party services we rely on our experiencing degraded service. All incoming calls are paused in order to mitigate negative patient experiences, and downstream scheduling conflicts.

Mon, Oct 20, 2025, 04:47 PM(2 hours earlier)